Issues to establish calls from musterpoint/elevator/intercom terminals.

Resolved

This incident has been resolved.
Posted May 28, 2026 - 16:03 CEST

Investigating

This only affects newer terminals, Does not affect older models.(VS50XX and DS22XX). We are currently investigating this issue.
Posted May 28, 2026 - 11:09 CEST
This incident affected: General.